0
\$\begingroup\$

I followed this guide to import a demos project, but when I set the class path of the module to the desktop, then click on the button of the main class field and select the DesktopLauncher class, there is no desktop module in the list. I can't run the imported project, because I have to create a custom run configuration named "Desktop" with the module "desktop" and the main class "DesktopLauncher".

How do I import and run a LibGDX project in IntelliJ?

\$\endgroup\$
0
\$\begingroup\$

Have you made sure you have let gradle import everything?

Usually intellij will say it found gradle files and ask you for settings, there you can enable auto import.

You might be able to rightclick and press build on build.gradle in the project root.

If you can already see a gradle tab in intellij (usually right side at the top) you can open that tab and press the refresh icon.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.