1
\$\begingroup\$

I have a mesh. A perfectly normal mesh, without any artefacts at all.

enter image description here enter image description here

However, when I import it into Unity, there are holes in it.

enter image description here enter image description here

After going through my UV mapping and normals, they are all mapped, have no faces with the normals going the wrong way (facing inwards) and have non-transparent textures over each mapped UV face.

Oddly enough, this mesh hasn't been split, despite its poly count and is one whole object, but yet - It has missing polygons. Is there any way to get Unity to recognise these faces?

Also, it is worth noting that these holes happen to be all the tris faces on this model, and are all (mostly) along the UV seames.

Question

How do I make the invisible faces show? What's going on?

\$\endgroup\$
  • 2
    \$\begingroup\$ How high is the polygon count? Did you conver the polygons to triangles? \$\endgroup\$ – Bálint Mar 15 '17 at 17:00
  • \$\begingroup\$ @Bálint Makes no difference. Besides, Unity automatically does it for you (like with most engines). As for how high? About 27k after converting quads to tris. \$\endgroup\$ – aytimothy Mar 15 '17 at 17:01
  • 2
    \$\begingroup\$ I think @Bálint is on the right path here. Unity only allows 2^16 indices, or 65536 in a mesh. 3 indices per triangle gives you 21845 triangles. All other triangles are just left out. \$\endgroup\$ – James Lambert Mar 15 '17 at 17:13
  • \$\begingroup\$ @JamesLambert that should give a warning / error when importing (at least it did when I tried it). Also, you can get 3 triangles with 4 points, so calculating like that doesn't really work. Anyway, try going inside the shape and looking outwards, see if you can see those triangles that way (if the triangles are setup the wrong way around, they will be visible from the inside and not the outside). \$\endgroup\$ – John Hamilton Mar 15 '17 at 17:30
  • \$\begingroup\$ Why do you need 27k triangles for a single torso/thing? \$\endgroup\$ – Bálint Mar 15 '17 at 20:11
-1
\$\begingroup\$

Could you post the import settings of the .fbx in unity?

You could try changing the Normals option or the Optimize Mesh and see if it helps.

\$\endgroup\$
  • 2
    \$\begingroup\$ This answer seems more like an attempt to ask for clarification, and should probably be left as a comment. \$\endgroup\$ – Gnemlock Mar 15 '17 at 23:11
-3
\$\begingroup\$

In edit mode in Blender, select all faces and press Shift + N or Ctrl + N. I don't remember. Maybe this will be helpful.

\$\endgroup\$
  • 1
    \$\begingroup\$ Hmm. What is the intent here? What are those shortcut keys supposed to do? What is the issue with the OP's model? \$\endgroup\$ – Vaillancourt Mar 15 '17 at 16:49
  • \$\begingroup\$ Have I tried normalising the faces (use the "Make Normals Consistent (CTRL+N)" command)? Yes. Otherwise, why would I have asked. \$\endgroup\$ – aytimothy Mar 15 '17 at 16:51
  • \$\begingroup\$ He probably just missed where you said you checked the normals; it's kinda buried, so I missed that too. \$\endgroup\$ – jhocking Mar 15 '17 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.