3
\$\begingroup\$

I'm trying to add my own splash on my Unity project. However, when I implement it, the splash is stretched vertically, real bad.

Here is the screenshot: My own splash in the build. How to fix this?

While the original splash is: How it should appeared :(

I'm not altering the settings for the sprite that much: The settings for the sprite. No major changes.

How to fix that problem? I'm using a 1080x1080 PNG file for the splash and Unity 5.5.0f for building the application. Altering the resolution of the PNG results no luck. Am I missing something important here?

EDIT: Sorry for the late mention, but I've made the border on the sprite editor. Still no luck. This doesn't change anything. Still stretched like hell.

\$\endgroup\$
5
  • 1
    \$\begingroup\$ This is most likely a problem with the sprite editor. Try going in there and changing the borders of the sprite. If not, it has to be the splash image settings under player settings. \$\endgroup\$ – John Hamilton Mar 8 '17 at 13:03
  • \$\begingroup\$ @JohnHamilton I've edited the question to include my sprite editor configurations. Still no luck. :( \$\endgroup\$ – Rama Alifiandy Mar 9 '17 at 14:21
  • \$\begingroup\$ Also, I don't found any sign to fix this problem on the Player Settings :/ \$\endgroup\$ – Rama Alifiandy Mar 9 '17 at 14:26
  • \$\begingroup\$ Check this : Check this: Splash Image/Splash Screen tutorial | WFG #002 youtu.be/YTpfrrXetNw \$\endgroup\$ – Kaysiy Sep 6 '19 at 18:48
  • \$\begingroup\$ Well, didn't expect this to be necrocommented. I have since moved on to Unreal Engine anyway. \$\endgroup\$ – Rama Alifiandy Sep 7 '19 at 2:47
6
\$\begingroup\$

Alright. So I just stumbled across the Import Settings, and found that the solution to this problem is just by setting the Mesh Type into Full Rect, nothing to do with the Sprite Editor. Newbies can miss this, because by default, Unity set the Mesh Type into Tight instead.

Actually, my bad I didn't experimenting with the Import Settings last time, so I apologize for this. But I guess it's a bit worth mentioning anyways.

\$\endgroup\$
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.