1
\$\begingroup\$

I don't have a dedicated GPU on my laptop and would like to know which settings to change in order to get semi decent performance. I don't care if the 3D camera will render everything pixelated.

At this moment when I try and run the First person shooter demo it will run around 40fps and when shooting the gum the frame rate drops to around 25fps.

I think my CPU is pretty descent for an laptop. Its an i7-3667U & I have 16gb ram. Intel HD Graphics 4000. Also I already have unreal installed on my SSD.

My goal is development only and I will use low poly models when possible.

\$\endgroup\$
2
\$\begingroup\$

By default UE4 has many post processing effects turned on that may lower your performance, especially on low end GPUs.

Go to Project Settings -> Engine -> Rendering

Then disable everything under "Default Postprocessing Settings".

Additionally, in the toolbar above your vieport (where you have a Play button) select "Settings" and "Engine Scalability Settings". There you can set the "Quality" to Low and you have a "Resolution Scale" slider. This slider allows you to use lower resolution, but it works only in Play mode, not in editor itself. You may also try other settings in "Scalability" group.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.