0
\$\begingroup\$

I'm following through Jesse Freeman's Lynda course Unity 5 2D Essential Training. The exercise files contain sprites with transparency. Here's a screenshot of one such sprite on the trainers screen (sorry it's so small):

Screenshot of screencast in Lynda

But here's how it looks in my scene in Unity 5.5.0F3:

Unity editor screenshot

I think that the sprite's alpha properties are set correctly, I have Alpha Source set to "Input Texture Alpha" and Alpha Is Transparency is checked:

Sprite inspector screenshot

When I open the PNG in PhotoShop the transparency is correctly set:

Photoshop screenshot

Why is the transparent area rendered as opaque in my sprite?

\$\endgroup\$
  • \$\begingroup\$ Ta, but I'm using the default built in "Sprites-Default" material \$\endgroup\$ – dumbledad Jan 31 '17 at 13:17
  • \$\begingroup\$ Have you checked it with having an actual background behind it? May be defaulting the white there because there isn't anything behind it for some reason.. Although it shouldn't \$\endgroup\$ – n_plum Jan 31 '17 at 14:53
  • \$\begingroup\$ It shows white when in front of other scene elements. \$\endgroup\$ – dumbledad Jan 31 '17 at 14:57
1
\$\begingroup\$

This may help:

"simply change the render queue:
- select Object Material
- change view to Debug Mode (Inspector Window top right drop down menu)
- change Custom Render Queue value for example 3000 => 3100
- now your object will be rendered before other transparent objects"

Check here first as it may be something simple like the format. For example, if you need True Color then you will need to select the format 'RGBA 32bit'.

Check here for more in depth explanations and solutions.

\$\endgroup\$
  • 1
    \$\begingroup\$ Thanks - it was the formatting. In the video he uses True Color which translates into the format RGBA 32bit in my version of Unity \$\endgroup\$ – dumbledad Jan 31 '17 at 15:25
  • \$\begingroup\$ No problem, sometimes it's just the simple stuff you don't catch that can be a real pain. \$\endgroup\$ – n_plum Jan 31 '17 at 15:26
  • 1
    \$\begingroup\$ I'd recommend removing the section about render queues settings, as this may be misleading for the symptoms shown. A misconfigured render queue can cause the object to render behind something it should be in front of, or act as a cutout on shapes behind it, but it won't introduce an opaque white in areas that should show transparency to a grey background as shown in the images in the question. Instead, it would be worth expanding on the texture format options and which ones are appropriate for sprites with transparency - don't rely too heavily on external links, since those change sometimes. \$\endgroup\$ – DMGregory Jan 31 '17 at 17:56
  • \$\begingroup\$ Do you mean all render queue information? And instead elaborate on the True Color solution \$\endgroup\$ – n_plum Jan 31 '17 at 18:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.