3
\$\begingroup\$

My Unreal Engine UI does not look sharp and is blurred on my 1080p monitor. Subsequently, the viewport is slightly blurry and edges are jagged. I have changed the setting of the viewport to "Cinematic," yet this still persists.

I have two images available where the first is mine and as you can see, the image is slightly blurred and text on the left-hand side is not sharp. My blurred UI

The second image is from a YouTube video which has been compressed (by YouTube) yet it still looks better.

Crisp UI from a YOUTUBE vid!

How can I make the UI more crisp and prevent the blurring?

Anyone?

\$\endgroup\$
  • \$\begingroup\$ can you please insert screenshot showing your ui information from inspector ( or kind of it ) and screenshot showing your ui is blurry ? \$\endgroup\$ – user6668201 Jan 20 '17 at 12:36
  • \$\begingroup\$ I have added pictures \$\endgroup\$ – Computing Corn Jan 20 '17 at 16:37
  • 1
    \$\begingroup\$ If you're asking about the appearance of the editor itself, consider asking on SuperUser - this might be a configuration setting in your OS affecting how it renders software interfaces generally (eg. UI scaling features for high-resolution displays) rather than a game development issue. \$\endgroup\$ – DMGregory Jan 20 '17 at 17:07
  • \$\begingroup\$ @DMGregory , its like only 10% chance he will find someone that is a game developer at super user + if he found one , only 25% chance that game developer use unreal engine , so i sure he ask it right \$\endgroup\$ – user6668201 Jan 22 '17 at 13:15
  • \$\begingroup\$ I'd agree, if the issue is exclusive to the Unreal UI. That would be an unusual case though. First I'd want to eliminate the possibility that it's an OS or screen resolution setting, which sounds more likely to me,, and that kind of expertise is not exclusive to games. \$\endgroup\$ – DMGregory Jan 22 '17 at 13:47
3
\$\begingroup\$

Being the clever piece of software it is, when UE4 is inactive for a certain amount of time- or more specifically if the frame rate of the editor has been below a certain threshold for a certain amount of time (if you've been editing the open level, blueprints or code as opposed to running your game in the editor for example) it automatically lowers the visual quality of what is displayed in the editor to save on CPU processing power. Note that this feature does not effect UI elements such as buttons and text and the like. Your editor can also appear like this straight off the bat, if you are loading a project that you have had open previously, where the frame rate of the editor was below the set threshold for an extended period, prior to you closing the editor.

Generally it will display a pop up briefly first giving you the opportunity to cancel the change, but if you ignored it or didn't see it (if you had switched out to your browser briefly perhaps or went and made yourself a sandwich) then the changes will be applied. Out of curiosity which version of UE4 are you running?

I"m running 4.14 and it automatically reverts the resolution and other quality settings to normal as soon as I click on an object within the editor, however it may not revert automatically on earlier versions, I'm not sure. In any event you can change it back manually by adjusting the Scalability settings- just click on the 'Settings' drop down above the editor, and select 'Scalability Settings'. You can also change the quality of the materials displayed in the editor and the preview rendering level with the two settings directly below if they are set lower than expected, but the scalability settings is usually the culprit.

I've included a link to Epics documentation on Scalability Settings so that you can read more about this feature, and make informed choices about the settings you adjust as opposed to taking a shot in the dark, however if you haven't already try clicking a few objects inside your level first, or perhaps simulating play mode to see if the settings revert automatically.

Note also that you can turn off this feature in the dialogue box that pops up in the future, or by unchecking the 'Monitor Engine Performance' in the scalability settings menu, though now that you know how and why it happens (assuming this post resolved your issue), it's probably better not to as it's pretty damn nifty in my opinion. I hope that helps!

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.