3
\$\begingroup\$

UPDATE :

The material does work on smaller objects like a simple sphere, but not on my big arena model, which is actually imported from blender, any suggestions?

UPDATE :

Tried to export as .fbx, but doesn't change anything.

I've imported this material pack : https://www.assetstore.unity3d.com/en/#!/content/13004

I tried to apply it to my mesh, but only weird things happen, I can't see the texture at all. So I tried to apply this material in the "shader calibration scene" and that worked without any problem, even updating to the standard shader worked fine. So I tried to fix it with the following things :

  • Rebaking lighting
  • Restarting Unity
  • Tweaking the material settings
  • Tweaking quality settings in Unity
  • Building the project

All these things couldn't fix it, but it should most likely be related to my project settings, since this material is working in another project (shader calibration)

Here are my quality settings :

enter image description here

I'm not sure, which information is needed to answer the question, but I can provide it if you ask for it.

Update with Object properties :

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Can you get a screenshot of the object properties? \$\endgroup\$ – Ryan white Jan 19 '17 at 12:29
  • 1
    \$\begingroup\$ I don't think you have to fix this in Unity side, I bet the problem is in Blender side. Does your Blender model have an UV map? Blender let people to apply textures nearly without any extra work thank to its projected coordinates, but in my experience they don't work with game engines and exporters aren't smart enough to auto generate the required UV Map (not that such a feature is required in an exporter). \$\endgroup\$ – Hatoru Hansou Jan 19 '17 at 12:31
  • \$\begingroup\$ Even if you are using an Asset Store material pack, the model still needs to have UVs. \$\endgroup\$ – Hatoru Hansou Jan 19 '17 at 12:34
  • \$\begingroup\$ I've imported a "blank" model from Blender, the only thing I've done to is was setting materials to specific faces, but no textures and stuff like this. I create my materials completely in Unity since the import doesn't work anyways. \$\endgroup\$ – TobiasW Jan 19 '17 at 15:31
  • \$\begingroup\$ So am I supposed to create the UV map in blender or Unity? I guess it's done in Blender right? @HatoruHansou \$\endgroup\$ – TobiasW Jan 19 '17 at 16:10
4
\$\begingroup\$

What is described in the question is probably due to missing UV data in the model (or all UVs set to zero).

To solve it, load the original model in Blender and add an UV map. You probably need to unwrap the model, and maybe manually adjust some UVs after unwrapping.

Just get to the point of seeing the model texture in Blender isn't enough, Blender can map textures on meshes without UVs but that won't export to most game engines (if not all of them).

The user asking the question already knows what follows but I'm adding it to the answer for a more complete answer

To unwrap a model

It is recommended to use a split view, with the UV editor visible in one of the views. To split views in Blender: https://www.youtube.com/watch?v=rhh513vUgME

Then, working in the view with the model, select model, enter edit mode, press U, in the context menu that appears click Unwrap or any of the unwrapping algorithms that Blender offers (try to minimize the amount of manual edit to the UVs you will have to do after unwrapping, to zero if possible).

enter image description here

Double check in the UV Map editor if everything is OK with the UVs, fix what you see is wrong. This is artist work and intuition plays a fundamental role.

enter image description here

Now go to the texture panel and check that you are using the UV map and not generated coordinates.

enter image description here

Finally export your model, probably FBX is the best available option when working with Blender and Unity. Or let Unity handle the blend file (I keep my blend files away from the Unity assets directory, long story, and only place there the FBX export. This is no standard procedure or anything, just my personal preference).

In the case of this question, the use of an external material probably means that the material already comes configured to use the UV data from the model. So the step of changing the properties of the texture panel in Blender may have no effect at all. When authoring both, your own models and materials, you probably need to check the texture panel in Blender.

\$\endgroup\$
  • 1
    \$\begingroup\$ I'm always impressed, when someone takes so much effort to answer questions for a community. Thanks you helped me a lot :) \$\endgroup\$ – TobiasW Jan 19 '17 at 19:38
  • 1
    \$\begingroup\$ This community helps me a lot always so I try to imitate the format of the answers that I liked the most. \$\endgroup\$ – Hatoru Hansou Jan 19 '17 at 20:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.