0
\$\begingroup\$

I followed the setup tutorial provided by Unreal from here but after setting up the pawn and the VR_GameMode you don't do anything with them. They are never added to the scene or anything and the default game comes with a "Player Start."

Is the "Player Start" object supposed to be removed? If you remove that then running the VR Preview shows the game from wherever your camera is in the viewport and there is no game location. Adding the pawn to the scene doesn't seem to do anything. The final image they show doesn't have the "Player Start" object in the scene at all and they never mention it so I'm unclear about how to complete this process.

Adding the pawn to the scene seems to have no noticeable affect on how the game is run in VR Preview. What's the proper last step?

After following the instructions exactly as-is the floor is way below the current start point and modifying the Z values as instructed has no affect on the floor. Moving the "Player Start" does, but this could have been done from the very beginning without doing any of the setup with the pawn or the GameMode.

\$\endgroup\$
1
\$\begingroup\$

You have to change the project settings to tell the level to pick your pawn as PlayableActor. This can be changes from eithert edit-> project settings -> maps**

or from the world settings.

\$\endgroup\$
0
\$\begingroup\$

My setup was:

  1. Remove PlayerStart
  2. Add a YourPawn on the map and adjust camera transform as you needed, also select Auto Posses Player 0 for the pawn.
  3. Override YourGameMode::FindPlayerStart() (in C++ or BP) to return the YourPawn on the map.
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.