1
\$\begingroup\$

Please refer to this video to understand the issue I am facing.

With camera movement, there is a strong white reflection that appears over the complete model. What settings do I need to change to fix this ?

\$\endgroup\$
1
\$\begingroup\$

This looks like a specular problem. Assuming you're using the Unity 5 Standard Shader, try turning down the Metallic and Smoothness sliders, or the Specular's Smoothness slider if you're using the Specular workflow.

If you're using the Metallic workflow, and you supplied a texture to the Metallic map, keep in mind that:

The Metallic levels for the material are controlled by the values in the Red channel of the texture, and the Smoothness levels for the material are controlled by the Alpha channel of the texture. (This means the Green and Blue channels are ignored).

(From Unity's Metallic Parameter Documentation)

Although, if you lower these sliders all the way, the smoothness won't have any effect.

If you still have the problem, you may want to look into the Lighting tab or see if there's any Reflection Probes that haven't been set up properly, but from the video it looks to be a specular issue.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.