0
\$\begingroup\$

I changed the units in Blender so they are identical to Unity 3d. If I make a 1m^3 box in Blender, it will import into unity as exactly the same size as the standard cube.

With 3ds max, I changed the unit setup to metric and made sure it was centimeters in the system unit setup tab. However, when I import an obj file made in Blender and used in Unity, it is absolutely tiny. I have to convert the model to meters on import and then, when exporting, I have to set the model scale to .01 otherwise it is enormous in the unity scene.

I've tried changing the max units to meters and nothing changed.

How do you change the max unit/grid setup so one grid unit is 1m^2 and exactly equivalent to unity's grid?

\$\endgroup\$
  • \$\begingroup\$ You should edit your title, because without reading it's not at all clear, that you have a problem with 3ds max. Also i think you are better to post this in a dedicated 3ds max area and not game development. \$\endgroup\$ – Yosh Synergi Dec 2 '16 at 10:49
1
\$\begingroup\$

Obj files don't save what measuring unit you are using, only coordinates. If you used meters and made a 1m3 cube, it would save something like:

(0,0,0) (1,0,0) (0,1,0) (0,0,1) (1,1,0) (0,1,1) (1,0,1) (1,1,1)

There would be no mention of meters or centimeters in that file. If you were to open that file in a program that uses centimeters, it would see it as a 1cm3 cube instead of a 1m3 cube, and vice versa.


I'm not proficient with 3ds Max, but from what I've seen, there are a few possible reasons why yours works the way it does:

  • First problem could be scaling. 3ds Max could be scaling your models to 0.01, you have to set that to 1 and I'm not sure how you do this, but this is most likely not the problem you have (see this link).

  • Second problem could be that you are using the wrong units as your export. You said you were using centimeters, where you need to use meters (see this link). You can change this from the interface menu (see this link).

\$\endgroup\$
  • \$\begingroup\$ Changing the export options to .01 and import options to 'convert to meters' worked. It seems Blender wins in terms of compatibility with Unity in this case. \$\endgroup\$ – OwenAlexander Dec 2 '16 at 22:35

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.