I am a beginner. I created a 3D project with a cube object, and I am getting this pink display, in the camera view.

Camera view in Unity 5

Why is the camera view pink?

  • \$\begingroup\$ It seems likely it has to do with that cube in the way, but could it be a missing skybox? \$\endgroup\$
    – tyjkenn
    Nov 30, 2016 at 19:53
  • \$\begingroup\$ Could you post a screen shot of your scene view, so we can see where the cube is in relation to the camera? Also if you could show the inspector view for the camera, that would be really useful as well :-) \$\endgroup\$
    – hobnob
    Dec 1, 2016 at 11:36
  • \$\begingroup\$ Which version of Unity do you have installed? I am facing the same problem (no cube in front or behind the camera), whole new project is PINK. I am facing this problem since the beginning and because of this I can't build any other Unity projects I downloaded from Unity examples. \$\endgroup\$ Jul 7, 2018 at 13:42
  • \$\begingroup\$ @GamesWarehouse4u the pink colour means Unity had some kind of problem compiling and using the shader programs used to draw materials or backgrounds in the viewport. There are a lot of potential causes for this - from errors accessing the shader files to errors communicating with your graphics driver. Try reinstalling the drivers for your graphics card, and then reinstalling Unity from scratch. If you're using a bleeding-edge/experimental version, try falling back to the last stable version to see if that helps. \$\endgroup\$
    – DMGregory
    Jul 7, 2018 at 13:55

2 Answers 2


You seem to have created a cube as a child of the camera, thus taking up the entire view port. Imagine placing a thumb in front of a camera's lens. Since the cube's material is pink (you seem to have deleted the default material), all you see is one side of a giant pink cube.

You can either:

  • Change the hierarchy of the cube. Click on the cube, hold the click, and drag it outside of Main Camera.
  • Set the Camera's "Near Clipping Pane" property to a different value, superior to 1 (which seems to be the depth of the cube).
  • \$\begingroup\$ I have changed it as you said. The camera view is still pink. :( \$\endgroup\$
    – Warda
    Nov 30, 2016 at 19:28
  • \$\begingroup\$ @Warda does changing the "X" Rotation on the Main Camera's Transform produce any effect? If you select the Main Camera from the Scene tab, does the Camera Preview still shows only pink? Have you tried deleting the cube altogether? What Unity version are you using? Could you try creating a new empty project and seeing if it works as intended? \$\endgroup\$ Nov 30, 2016 at 19:35
  • \$\begingroup\$ I created a new scene. It still gives me pink camera view. tutorial I'm following. The person has the camera view brown and the sunset. I am not having this.. why? help me, please. \$\endgroup\$
    – Warda
    Nov 30, 2016 at 20:00
  • \$\begingroup\$ I'm using Unity 5. Yes, if I select the Main Camera front from the scene tab, still pink. I tried a new project thrice.. IDK, what's happening... \$\endgroup\$
    – Warda
    Nov 30, 2016 at 20:06
  • 1
    \$\begingroup\$ Also, as I have just confirmed, a camera inside a cube looking out does not see the cube (given that all the facing normals point away from the camera). This seems further supported by the fact that the cubes mesh renderer appears disabled in the screenshot. \$\endgroup\$
    – Gnemlock
    Dec 1, 2016 at 0:16

What you see is a default material. It is nothing to be overly concerned about; it serves as a placeholder. The only problem appears to be the colour; In my experience, the default material is usually a light grey. In the recent version of Unity I downloaded, version 5.5.0f3, it is black.

If you wish to try resetting your default material colour, I found other users who have experienced similar issues, on installing Unity. One user has found a solution, which seems to work, most of the time:

Answer by Javier_8 · Jun 23, 2015 at 10:59 PM
I fixed it.
Edit->Preferences->GI Cache->[Clear Cache]
- "Unity 5 default shaders are pink" @ Unity Answers

Remember that this is the default material. Pink or not, you should still aim to replace this material at your earliest convenience, if only to a more suitable prototype material. My recommendation would be to simply ignore the pink; pink is far more noticeable than grey, making it much easier to tell if a particular mesh needs an actual material. You can find information on creating and making materials at the Unity manual.

As for what is being displayed, I can only speculate, given the information that has been provided.

First and foremost, it is not the cube. We know this for two reasons:

  1. In the inspector, your cube has its MeshRenderer disabled. This is the part that renders the mesh of the cube. While disabled, your cube is not rendering, and you will not be able to see it from the game view.

Disabling the "Mesh Renderer" on an object makes it invisible to the game camera.

  1. From the inside of a cube, all normals (values that tell us the facing direction of each face) face away from the camera. When a normal faces away from you, the face does not render, even when the MeshRenderer is enabled, as you can see in the following animation.

The default camera does not render faces from the "inside"; from the inside, the cube is invisible, even when it would otherwise be visible.

Given that the only other object in the scene is a directional light, I would speculate that it is the Clear Flags setting, on your camera. You might have this set to Skybox, with the default shader interfering with the default skybox. It is entirely possible that you might simply have it set to Clear Colour, and actually have the colour manually set to pink.

Changing the camera "Clear Flags" value to "Solid Colour" has a similar effect.

  • \$\begingroup\$ Firstly, I respect your answer. I have still had the same problem. The issue is not a cube. When I Press Game tab, it shows me pink with setting the Clear Flag as Skybox. Now, I couldn't get this?? :( \$\endgroup\$
    – Warda
    Dec 1, 2016 at 4:51
  • \$\begingroup\$ Have a look at my again pink screen. Game tab \$\endgroup\$
    – Warda
    Dec 1, 2016 at 5:04
  • \$\begingroup\$ @Warda, as I said, the only other explanation I could give would be the actual Skybox having the same issues. Did you reset your GI Cache? \$\endgroup\$
    – Gnemlock
    Dec 1, 2016 at 5:35
  • \$\begingroup\$ Yes, I reset the GI Cache. \$\endgroup\$
    – Warda
    Dec 1, 2016 at 5:54
  • \$\begingroup\$ @Warda, you havnt saved a build of your project, have you? \$\endgroup\$
    – Gnemlock
    Dec 1, 2016 at 6:04

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .