1
\$\begingroup\$

Unity displays in poor quality on my computer (the software itself), I was wondering how to change resolution/display settings?

\$\endgroup\$
  • \$\begingroup\$ What is poor quality for you? Is it running slow? The UI is blurry? Is the screen corrupted? \$\endgroup\$ – rlam12 Nov 28 '16 at 6:11
  • \$\begingroup\$ The UI is blurry. \$\endgroup\$ – Kitty Nov 28 '16 at 6:34
  • 1
    \$\begingroup\$ Blurry UI usually results from trying to display images at a resolution slightly different from the native resolution of the device. Each real pixel on the screen ends up falling between pixels of your textures, leading to interpolation which makes it look fuzzy. If you edit your question to include screenshots of your current setup (including both the rendered output and how it's been authored in the scene/hierarchy/inspector) we should be able to guide you in correcting the scale to get crisper content. \$\endgroup\$ – DMGregory Nov 29 '16 at 22:30
  • \$\begingroup\$ Is the Unity (program)'s UI blurry or is it the in-game UI that you made which is blurry? Adding a screenshot would be really useful. \$\endgroup\$ – John Hamilton Dec 3 '16 at 17:24
  • \$\begingroup\$ If it's the editor itself that's blurry, it could be your OS applying a "scale text for high-resolution displays" feature to upscale the whole interface. This can usually be disabled in the properties on the executable. \$\endgroup\$ – DMGregory Jan 15 '17 at 21:07
4
\$\begingroup\$

It appears that the resolution of your computer is higher than what Unity normally handles. To resolve this:

  1. Find the Unity.exe, This is normally located at C:\Program Files\Unity\Editor\Unity.exe
  2. Right click on the .exe and select properties.
  3. Navigate to the compatibility tab, and check the box that says: Override high DPI scaling behaviour.
  4. Select scaling performed by application from the dropdown.
  5. Click apply and ok.

The next time Unity runs it will not be blurry.

\$\endgroup\$
1
\$\begingroup\$

Have you tried looking in the player options?

Edit > Preferences > Player Options

Usually there, are graphical options for every platform you are developing, maybe playing with those options you get many results

You can try increasing the quality of the textures too, but then, they will be very large

\$\endgroup\$
0
\$\begingroup\$

As you commented :

a

Everyone also have this problem , and the problem is come from the unity itself , for example :

  • Resizing image / sprite scale make the image blur ( to prevent blur you must make your image in high definition so unity will make it not blur as long as possible )

  • Resizing text , i sure this is your problem that the text is getting blurry , to fix text blur do this simple step :

  • Click which text you want to stop - blur

  • Change the font to 10000
  • Change the text scale ( Not Text Font ! ) as small as the text will show like what you want

This will need alot of try and work , also if this not answer you looking for , tell me i can delete this answer ;) .

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.