0
\$\begingroup\$

I'm making a practice game (generic space invaders clone) in Gamemaker Studio. However, there appears to be a problem with the images. While they look acceptable in Gamemaker Studio (not amazing, due to stretching effects, but acceptable for a practice project):

In Editor Image

However, once I compile the project down to an application I get this blurring effect:

In Game Image

Can anyone tell me what's causing this, and how to turn it off?

\$\endgroup\$
1
\$\begingroup\$

As far as my eyes see on your example, the upper part of those sprites have hard edges.

Bilinear interpolation blends from color to color, if you use a bigger resolution for your sprites than the sprites base resolution.

enter image description here

sooo Turn off the Bilinear Interpolation on the Sprite images. Set it to "point". https://docs.yoyogames.com/source/dadiospice/002_reference/drawing/texture_set_interpolation.html

This probably leads to another problem, depending on sprite resolution and virtual resolution and screen resolution, see here:

https://gamedev.stackexchange.com/a/129363/86773

\$\endgroup\$
0
\$\begingroup\$

It appears as if the view port size (which can be adjusted in the Views tab) is larger than the background you're using, so the image is stretched. If this is the size you want, go into the Global Game Settings, open "Windows" and uncheck "Interpolate colors between pixels" and the background should be stretched in a more pixelated way.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.