1
\$\begingroup\$

This is a follow-up question on a previous issue I faced with a game I'm trying to make. It's in a 2D isometric perspective and the levels are created from individual tiles. A simple 3x3 map can be seen here:

example 3x3

The tiles are individually added to the sprite batch, and (at least, this is what I think is happening) each one get anti-aliased on their edges, resulting in a small blur which creates the thin edges that you can see in the picture.

To make matters worse, I actually want to provide a bit more complex tiles in my game than what is displayed above. For example, I want to be able to show roads. To do so, I wanted to layer multiple sprites on top of each other, resulting in the picture below:

road

I think you can see where I'm going here. The same problem that I described with the aliasing is now occuring aroud each texture. So sad.

I know I can use Point sampling to make the textures align pixel perfect, but even though this does work, the (relatively) high resolution textures really do not seem fit for such a setting:

those edges

I mean, these edges simply need to be anti-aliased.

So, my question to you all is: Is there a way to stitch my tiles (and tile-pieces) together in a way so that anti-aliasing does not ruin it with those annoying edges, while still being able to produce a nicely anti-aliased result?

I hope there is, and that someone here can show me how :)

Thanks,

Rutger

Edit 1: Changed the title to be more representative to the problem (I hope?)

\$\endgroup\$
  • \$\begingroup\$ Maybe it's a bug in the placement logic. Show us the part where you project the tile's coordinate to isometric coords. \$\endgroup\$ – Bálint Nov 11 '16 at 11:55
  • \$\begingroup\$ You could also oversize the tiles by one pixel in each direction \$\endgroup\$ – Bálint Nov 11 '16 at 11:56
  • \$\begingroup\$ @Bálint, Thanks for the response. I see your point, but this is not the problem. If it was, it would also show gaps when using Point sampling, which is not the case. Oversizing will result in misaligned textures, which I also do not want. \$\endgroup\$ – Rutger Nov 11 '16 at 12:08
  • \$\begingroup\$ Unfortunately still not having luck in pinpointing what is causing the problem and how to fix it. I hope someone knows what is causing this and is able to respond? :) \$\endgroup\$ – Rutger Nov 14 '16 at 8:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.