0
\$\begingroup\$

I made sprite assets in Krita and I exported them as .PNG files. When I import the files into Unity assets, however, they become a lot darker than the original colors. So far, I haven't found the issue, and I was wondering what's going on?

My images appear particularly dark.

\$\endgroup\$
  • \$\begingroup\$ Which shader are you using.? I think you should use unity -> Texture. it give you perfect result with texture. \$\endgroup\$ – hardwork Sep 21 '16 at 3:50
  • \$\begingroup\$ If you want transparent then, Use unity -> Transparent. \$\endgroup\$ – hardwork Sep 21 '16 at 3:51
  • \$\begingroup\$ Do you have a gamma or color correction profile embedded in the PNG file? These can cause issues in some tools. I never worked with Krita, but you might want to check the export settings for PNG images. \$\endgroup\$ – Philipp Sep 21 '16 at 7:53
  • \$\begingroup\$ Edit -> Project settings -> Player -> Other settings -> Color space: Change it to Linear (or gamma if linear if linear is already selected). Does it fix it? \$\endgroup\$ – Leo Sep 21 '16 at 7:53
  • \$\begingroup\$ Philip how do you check of the PNG file has gamma or color correction?\ \$\endgroup\$ – user199845 Sep 21 '16 at 11:43
1
\$\begingroup\$

I was experiencing the same problem and this is how I managed to finally resolve it.

In Krita under [Image] > [Properties] I set my profile mode to "sRGB built-in"

kriat image properties

After that I just re-exported as PNG and imported the new image to Unity, and color was as fine.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.