1
\$\begingroup\$

It's my first day using Unity, so be gentle :)

I've spent a good number of hours trying to find the solution to this problem that I'm having when trying to Build & Run my GearVR application in Unity.

I'm aware people have had similar issues, but most of the solutions seemed to boil down to duplicate .jar files in the project's assets folder -- something that I don't have after checking numerous times to make sure I'm not going insane.

So after getting the error message: "Unable to convert classes into dex format", I then get the following error output:

CommandInvokationFailure: Unable to convert classes into dex format.
C:\Program Files\Java\jdk1.8.0_60\bin\java.exe -Xmx2048M -Dcom.android.sdkmanager.toolsdir="C:/Users/MichaelAC/AppData/Local/Android/sdk\tools" -Dfile.encoding=UTF8 -jar "C:\Program Files\Unity\Editor\Data\PlaybackEngines\AndroidPlayer/Tools\sdktools.jar" -

stderr[
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/facebook/androidcompat/AndroidCompat;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/oculus/aidl/RemoteConstants;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/oculus/aidl/RemoteConstants$EntitlementResult;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/oculus/aidl/OVRServiceInterface;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/oculus/aidl/OVRServiceInterface$Stub;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/oculus/aidl/OVRServiceInterface$Stub$Proxy;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/facebook/sign/lib/FBSignVerify;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/facebook/sign/lib/FBSignSigner;
Uncaught translation error: java.lang.IllegalArgumentException: already added: Lcom/oculus/appmanager/vrsign/VRSignVerifier;

UNEXPECTED TOP-LEVEL EXCEPTION:
java.lang.RuntimeException: Translation has been interrupted
at com.android.dx.command.dexer.Main.processAllFiles(Main.java:608)
at com.android.dx.command.dexer.Main.runMonoDex(Main.java:311)
at com.android.dx.command.dexer.Main.run(Main.java:277)
at com.android.dx.command.dexer.Main.main(Main.java:245)
at com.android.dx.command.Main.main(Main.java:106)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
at java.lang.reflect.Method.invoke(Method.java:497)
at SDKMain.main(SDKMain.java:129)
Caused by: java.lang.InterruptedException: Too many errors
at com.android.dx.command.dexer.Main.processAllFiles(Main.java:600)
... 9 more

Now, the only two jar files I have (that were included in the UnityIntegration package are vrlib & vrplatlib. As far as I can see, it seems to be vrplatlib that is causing the problem.

If I remove these two jar files (or even just vrplatlib) from the assets folder in my project, I get "Failed to build the APK. See console for more details" with even more error output.

Thanks for any & all help.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.