0
\$\begingroup\$

Follow up/related question to: Things disappear in front of Canvas

I'm having a very similar problem, where things are not appearing in front of my canvas. This time a particle system. I have tried the suggestions outlined in my previous questions (which worked then) but this time none of them will work:

enter image description here

You can see that the particle system is on top of the children and also I have added a canvas and overwritten sorting (the two suggestions in my previous post) yet the particles are not visible in front of the canvas.

\$\endgroup\$
1
\$\begingroup\$

For Particles, you need to alter the Renderer Sorting Order. Specify the sort order similar to the Canvas sort order, where you would like the Particles to be.

enter image description here

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ Unfortunately doesn't work. The sort order of Canvas is 0 and I tried setting the sort order on the particle system higher but nothing. Could it be something else? \$\endgroup\$ – user3078100 Aug 26 '16 at 7:50
0
\$\begingroup\$

Divide your UI objects into two parts. Fixed background, gradient etc and HUD, Buttons, Popup etc.

Render fixed UI objects in a Camera screen space canvas. Render others in a Overlay screen space canvas. Scenes end up using multiple canvases usually.

Reset particle transform in inspector as you normally do for other objects.

enter image description here

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.