-3
\$\begingroup\$

They are extremely ugly? I can't figure out why.

enter image description here

\$\endgroup\$
  • 1
    \$\begingroup\$ Looks pretty normal. What do you mean by "They are extremely ugly"? \$\endgroup\$ – Gnemlock Aug 25 '16 at 9:42
  • \$\begingroup\$ I can't even see the image, it is blocked by my proxy. \$\endgroup\$ – jgallant Aug 25 '16 at 9:48
  • \$\begingroup\$ First of all, this is editor view, so in game they might look different, unless you are using "world location" setting. Next, you can always customize UI by changing different settings on it, like text size for Text object of button. \$\endgroup\$ – lentinant Aug 25 '16 at 10:16
  • \$\begingroup\$ It looks exactly the same in game. \$\endgroup\$ – user3078100 Aug 25 '16 at 10:50
  • 1
    \$\begingroup\$ Please post a screenshot of the inspector settings of the "Play" text object, the button object and any parent objects when they have. \$\endgroup\$ – Philipp Aug 25 '16 at 14:15
2
\$\begingroup\$

I'm not completely sure but I do have two ideas for you to try:

  1. Increase the texture resolution to make it more sharp.

  2. It doesn't look to be using distance fields, just regular bi-linear filtering. Read about Distance fields, which is one of the best ways to render sharp text, maybe this will help.

\$\endgroup\$
  • \$\begingroup\$ It in fact looks like the buttons are using the default Unity fonts, which as far as I have been told, are very low quality, and only really suitable for prototyping. A higher quality font would be needed for suitable readability. \$\endgroup\$ – Gnemlock Aug 25 '16 at 14:09
0
\$\begingroup\$

It's scene view in 3D. Look at "game" window in Unity or open, if you closed it. You can also click "2D" in scene window. Here: How to open Game window in Unity / change view

\$\endgroup\$
  • \$\begingroup\$ That's not the problem. The buttons like like this even in game. \$\endgroup\$ – user3078100 Aug 25 '16 at 10:49
0
\$\begingroup\$

You should edit your Import Settings fields to fit the image to your desires (this is done by clicking on the texture in the Project Browser window):

https://docs.unity3d.com/Manual/ImportSettings.html

By changing Wrap Mode to Clamp, Filter Mode to Point, and setting the highest possible resolution in the Max Size list, and setting the Format to Truecolor.

Something like this should be enough:

settings

Just click Apply and that's all!

Good luck!

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.