0
\$\begingroup\$

So im building a game in GameMaker(A engine im good with), the development is going great and im making good progress. (Not going to go into detail about the game, its unrelated) but the problem i have is that when i do an update the player is required to start a new game as you cant load an old world into the new version (Not sure why, although i think i know) and i want a system that will just update the players current world with the new items, creatures etc. i have tried making the game use older versions of the save file, but it just loads the save file without the new items and creatures.

Edit i think i cant load a old world into the updated game because of it only having the save for the old items etc.(Not sure if this is correct though) Edit 2.0 the version is the games version, say if i tried to update to version 2 and the save is version 1, it wont load version 1 with the updated stuff in version 2.

\$\endgroup\$
3
  • \$\begingroup\$ It's unclear what you need: what 'version' are you referring to? Your own game version? GameMaker's version? Do you own the save-file format? If so, it's not clear why you can't load your data properly and convert it... \$\endgroup\$ – Vaillancourt Aug 8 '16 at 12:25
  • \$\begingroup\$ Sorry ill update to make it more clear, the version is the games version, say if i tried to update to version 2 and the save is version 1, it wont load version 1 with the updated stuff in version 2. \$\endgroup\$ – Ryan white Aug 8 '16 at 12:29
  • \$\begingroup\$ Sort of, i think it has helped my answer though. Ill mark this as solved or something. \$\endgroup\$ – Ryan white Aug 8 '16 at 13:15

Browse other questions tagged or ask your own question.