0
\$\begingroup\$

So I downloaded Asset Store Tools in the Unity Asset Store. When I upload my asset to my package, I get this popup:

Wrong project path The path selected must be inside the currently active project. Note that the AssetStoreTools folder is removed automatically before the package enters the asset store.

My Unity is version 5.4.0b25. I've tried other assets and reinstalled Unity, I still get the same popup.

Screenshot: Popup

\$\endgroup\$
  • 1
    \$\begingroup\$ So, what's the project path? What's the asset path? \$\endgroup\$ – MichaelHouse Jul 12 '16 at 22:40
  • \$\begingroup\$ @Byte56 the asset folder i'm gonna post to the Asset Store. \$\endgroup\$ – Moddwyn16MC Jul 12 '16 at 22:41
  • 1
    \$\begingroup\$ What are the literal paths... Is the asset inside the project path? \$\endgroup\$ – MichaelHouse Jul 12 '16 at 22:42
  • \$\begingroup\$ @Byte56 The asset is inside a a folder in the project path. Folder image i just click the ModUI folder then click open then the popup shows \$\endgroup\$ – Moddwyn16MC Jul 12 '16 at 22:50
  • \$\begingroup\$ I'm guessing the Asset Store Tools folder needs to be inside your ModUI folder. \$\endgroup\$ – MichaelHouse Jul 12 '16 at 22:54
1
\$\begingroup\$

This question has been posted several times on the Unity forums, and while I should think one would run into it before posting on here, I will repost it just in case.

This one answer popped up across all iterations I could find, most commonly marked as the most useful answer.

To quote:

Hi :),

just an adjucated guess[sic]: setting the category of your product to Complete Projects in the AssetStoreManager seems to do the trick.


The only user that did not find it useful later put it down to the fact that they were using an older version for the assets, and a beta version of Unity. If the above does not work, it would be a good idea to ensure you are uploading with the most recent stable release of the software.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ Thank you for your answer, it's the first time I saw this answer. But sadly it didn't help. I have the latest stable unity (5.4.1), the project is on the same version, the category is set to Complete Projects. But it just doesn't work, does the same exact error :(. \$\endgroup\$ – xtrimsky Oct 14 '16 at 10:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.