-1
\$\begingroup\$

I have a canvas on a camera set to it's screen space (not as a child of the camera)

I have my camera rotate on the y and x axises but whenever I move it on the x axis (up and down) the canvas doesn't follow it's rotation and is seen from a weird perspective from where the camera rotated.

this is what I see.

On the y axis it works fine and follows the camera.

Anyone else had this issue?

enter image description here

\$\endgroup\$
6
  • \$\begingroup\$ can you add a screenshot of canvas components and the UI object (the one that moving)? I only see the screen space canvas and UI object relative rotation only when canvas render mode in World Space or the main camera is child of the screen space canvas. Which is not very usual way. \$\endgroup\$ Commented Jul 6, 2016 at 18:51
  • \$\begingroup\$ @SP added a photo of the components in canvas \$\endgroup\$ Commented Jul 7, 2016 at 12:18
  • \$\begingroup\$ is Cam Cam 1 your main camera that rotating? \$\endgroup\$ Commented Jul 7, 2016 at 14:28
  • \$\begingroup\$ @SP. Sort of yes the small cameras are the ones that are rotating (they are objects that have a camera child on them) and the big camera in the center just mimmics their rotation and position \$\endgroup\$ Commented Jul 8, 2016 at 12:56
  • \$\begingroup\$ Add a screenshot how the objects are placed in hierarchy tab. Add the code to question details. Put everything necessary there if no problem with that. \$\endgroup\$ Commented Jul 8, 2016 at 13:10

2 Answers 2

0
\$\begingroup\$

I just solved this in my project. My Canvas was a child of a camera in a FP Controller, which scale was not (1,1,1), but (1,0.8,1). The tilting of the GUI was then scaled, thus seemed to be tilting in a different angle.

\$\endgroup\$
-1
\$\begingroup\$

I do not fully understand your issue, however, it may be because you are not scaling your Canvas.

enter image description here

You may want to try adding a Canvas Scaler component, and play around with the settings. Possibly set it to Scale with Screen Size, and then set the Match value to 0.5f.

If this is not helping, possibly try to provide an animated gif of your issue.

\$\endgroup\$
2

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .