After I downloaded unity 5, it became very power consuming. For example, my pc becomes hotter and makes a lot of noise. Also building, compiling, baking of game takes a lot of time. I am making a multiplayer game and need to build the game almost on every change, but it takes hours or sometimes it doesn't even build the game. There are also bugs with directional light, it doesn't work. So yeah, any suggestions?

My internal PC specs: Intel core i3-3130M, 8gb of ram, video card: Intel R4000

I installed unity 5 after Windows 10 came out, maybe it's something with the OS? Also yesterday, I updated Unity but with the same problems.

Also here are some screens:

Directional light is turned off but everything except models is dark, i mean terrain is black.

directional light problem

Also this baking process is more than one hour and stays on 5/11 clustering | 41 jobs

enter image description here

  • 1
    \$\begingroup\$ What "Core i3"? Intel is using the "Core-i" designation since 2007. An i7 from the Nehalem generation is magnitudes slower than an i3 from the most recent Skylake generation. Also, a Google search for "Intel R4000" only returns an obscure Toshiba CPU from 1991, not a modern GPU. \$\endgroup\$
    – Philipp
    Jun 15, 2016 at 8:33
  • \$\begingroup\$ @Philipp do you really think it's because of specs? i don't, because this problem is something new, that i hadn't. but btw i have i3-3130M 2.6 ghz 4 cpus \$\endgroup\$
    – Nick
    Jun 15, 2016 at 8:43
  • \$\begingroup\$ @Philipp, this issue is quite common. It does not appear to be spec-related (though low specs may encounter greater issue). \$\endgroup\$
    – Gnemlock
    Feb 28, 2017 at 4:25
  • \$\begingroup\$ Note that I encounter this problem on latest gen i7s and late model i3s, on 8gb and 4gb of RAM. In most cases, Unity does not lack performance (as it is running well below its requirements / capacity), but appears to "hang" at this stage. Of late, I have been able to confirm this problem with basic meshes (the cube and the cylinder, for example), and remaking the object exactly as it was before seems to fix it (as per my answer, I believe this is a problem caused by duplicating objects and the sharedMesh). \$\endgroup\$
    – Gnemlock
    Feb 28, 2017 at 4:28

2 Answers 2


Go to Lighting tab beside Inspector tab. Under Precomputed GI make the value of Realtime resolution to 0.02 (lower than default). It will reduce bake time. It won't look good but will work fine.

You can keep auto bake off after that baking done. Better CPU will help reducing time. Dedicated graphics card helps working Unity 5 better.


The issues reported describe the "infinite clustering" bug. We have a much better name for it, in my team, but it is not appropriate for this format.

The "infinite clustering" issue appears to be a common occurrence, in Unity. I have ran into the problem many times; in many cases, found online , this is resolved as being a bug. This problem can lead to severe performance issues, on lower-speced computers; it can also lead to difficulties, when building, as the "infinite clustering" may need to complete before your project will build.

I have found two general "fixes", neither of which require changing your lighting settings to have adverse impact on your scene:

Clean the GI Cache

Cleaning the GI Cache can fix this problem. I find it far less reliable, but it is also far more accessible.

Go to Edit > Preferences and select "GI Cache" from the left tabs. From this window, simply select "Clear GI Cache". With any luck, this will solve your problem.

Replace the "problem meshes"

At the end of the day, this problem appears to be caused by particular meshes, in your scene. The closest speculation I can give is that it relates to the way the MeshFilter object handles it's mesh and sharedMesh properties; the "problem meshes" have always been duplicates of "no-problem meshes", in my projects.

I resolve this problem by simply working out which meshes are causing Unity to cluster. The message tells you how many there are; it is the amount of jobs. In the above case, there are 41 jobs, so there would be 41 problem meshes. Finding the meshes can be tedious. The only method to reliably identify them, as I have found, is very procedural. You might prefer to reduce the lighting, such as in SP's answer; if you favor quality, the extra work is worth it.

Start by creating a new empty game object. This will be your "safe" folder, so to speak. Name it "safe", to help you organise your objects with greater ease. With your "safe" object created, select all of your other objects, and disable them. You should notice that Unity is no longer clustering. As you re-enable individual game objects, the "problem objects" will trigger the clustering, again. If the objects do not, move them to your safe folder. If they do, disable them, and leave them aside. You may even want to make an "unsafe" game object, to house these objects as you do the "safe" objects.

Eventually, you will be left with a select group of "unsafe" objects that all trigger clustering. Simply recreate these objects. The new objects should be free from clustering, allowing you to delete the "unsafe" objects, and carry on with greater ease.

Some final tips, in regards to this process:

  1. Enable parent objects, first. If they do not trigger clustering, all game objects inside are safe, and you can freely move the parent object to the "safe" game object.

  2. If a parent object triggers clustering, it may very well be the children. Complete the same process, moving further into the parent game object hierarchy. If the "problem objects" are few, it may be worth disabling them but moving the entire object into the safe folder. You will have to remember to come back and fix these objects, as without being in the "unsafe" game object, they will not be as easily listed as the other "problem objects".

  3. If you identify a "problem object", look to see if you have any duplicates of that object, in your scene. It is very likely that any duplicates of your "problem object" will also cause this issue, so this may help you identify the other "problem objects" more quickly.

  4. In regards to recreating duplicated objects, try duplicating the new object to replace the others. In my experience, this does not necessarily cause clustering, and you can tell straight away.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .