Is there any proper way to use antialiasing, while rendering to a RenderTarget2D and using Monogame?

I do this:

renderTarget = new RenderTarget2D(GameData.GraphicsDevice,
    pp.BackBufferWidth, pp.BackBufferHeight, false,
    GameData.GraphicsDevice.DisplayMode.Format, DepthFormat.Depth24,
    4, RenderTargetUsage.DiscardContents);

but AA is disabled despite setting multiSampleCount to 4. The hardware supports it and it works if rendering directly to the back buffer.

I googled around and it seems it used to work for XNA, but for Monogame I found this: https://github.com/mono/MonoGame/issues/1162

This link suggests it's an open issue and is from 2013. This is hard to believe for me, because it would effectively make using Monogame render targets unusable for most applications..



You must log in to answer this question.

Browse other questions tagged .