1
\$\begingroup\$

I am using a World Space Canvas, with a UI Text on it, using the Outline script, to produce the following text. I'm noticing a number of strange artifacts on the text, as seen below. Note for instance the yellow/black blog next to Tortuga, and the a in Tortuga not looking correct. There are others as well.

enter image description here

The same artifacts appear in my Scene view, so it leads me to suspect that it might be something Unity is doing that is odd. I've tried removing the outline, but I still see artifacts. Here is the text settings:

enter image description here

And here is the Canvas, which is the parent of the text:

enter image description here

Any idea how to remove these compression type artifacts? Thanks!

EDIT A few things tried:

  1. Removed outline: See photo below.
  2. Using an imported font with a high font size (64) set.
  3. Changing the font size from low (1) to high(50) in the Text window.
  4. Set all scaling to 1.

enter image description here

\$\endgroup\$
2
  • \$\begingroup\$ Take a look here: answers.unity3d.com/questions/715637/… \$\endgroup\$
    – jgallant
    Commented Apr 19, 2016 at 12:25
  • \$\begingroup\$ I started with the font size set at 12. The font size actually doesn't seem to make a difference for reasons I can't understand, but that's another issue entirely... \$\endgroup\$ Commented Apr 19, 2016 at 12:27

2 Answers 2

1
\$\begingroup\$

That is because the way the Unity Outline works, it will put a bunch of gross artifacts around your original text.

You can reduce the number of artifacts by raising your font quality, and making sure that you set the Outline alpha to 1.

Also try changing the Outline distance to negative values, which may help alleviate the artifacts.

Bottom line is, the Unity Outline implementation is pretty bad. I also stumbled upon this but I opted to not use it as it seems to be quite expensive in terms of CPU usage:

https://github.com/n-yoda/unity-vertex-effects

\$\endgroup\$
6
  • \$\begingroup\$ I didn't post it, but the same kind of artifacts appear with outline disabled. The alpha is 1. How does one increase the font quality? \$\endgroup\$ Commented Apr 19, 2016 at 10:34
  • \$\begingroup\$ What is the font size you imported at? \$\endgroup\$
    – jgallant
    Commented Apr 19, 2016 at 10:35
  • \$\begingroup\$ This was using the default arial font. \$\endgroup\$ Commented Apr 19, 2016 at 10:35
  • \$\begingroup\$ Ah, ok well you should try to import the Arial font in manually, and then changing the size, to get a higher definition version loaded into your Unity resources. Try it, sure to improve on the text rendering. \$\endgroup\$
    – jgallant
    Commented Apr 19, 2016 at 10:37
  • \$\begingroup\$ I am using the same library in my current project and it works well so far. Although I don't have enough outlined text on the screen at once that performance could be an issue. \$\endgroup\$
    – Philipp
    Commented Apr 19, 2016 at 10:42
0
\$\begingroup\$

The Unity rendering issue was known to have issues, I reported this as a bug and it was accepted. The real solution is to use TextMeshPro, which Unity has since purchased, it is a much cleaner text rendering engine.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .