0
\$\begingroup\$

I recently bought a new laptop, with Intel i5-5200U HD graphics 5500 and AMD Radeon R5 M230 2GB and 8gb ram, and heres what happens with my Unity: If open it, minimize it and then maximize again, it'll render some weird black screen in random areas of the editor, like this:

enter image description here

enter image description here

But, if I instead of minimizing unity and just opened other window , when I go back to unity nothing happens, no black weird "squares". So this just happens when I minimize unity itself and then maximize it, if I maximize another program over unity and then open unity again, it will not happen. Can anyone please tell me why this happens??? I always have to restart unity.... Is this a problem with my video card? plz help

\$\endgroup\$
  • \$\begingroup\$ if you're running windows try updating your video card drivers \$\endgroup\$ – Leggy7 Apr 15 '16 at 10:09
  • \$\begingroup\$ but its already updated... \$\endgroup\$ – khofez Apr 15 '16 at 10:22
  • \$\begingroup\$ You have dual graphics, I'm not currently aware of how AMD implement this but you should try setting it so that Unity only uses the 'high performance' graphics. There's probably a driver utility to let you do this. Essentially, try forcing Unity not to use the Intel graphics. I've had a few problems with the editor having graphical glitches and corruption and forcing use of a dedicated GPU normally clears them up. \$\endgroup\$ – Joe Apr 15 '16 at 11:27
  • \$\begingroup\$ Idk how to do that, i tried disable intel graphics but it didnt work, i tried run unity from amd control panel but it didnt worked too, idk what to do, and its just with unity \$\endgroup\$ – khofez Apr 15 '16 at 14:00
  • \$\begingroup\$ This looks like an engine bug you should contact Unity support about. \$\endgroup\$ – DMGregory Apr 15 '16 at 17:04
1
\$\begingroup\$

If you have dual graphics: force Unity not to use integrated graphics, and then restart Unity.

I switched from Intel integrated graphics to nVidia graphics for Unity in

NVIDIA Control Panel 
  -> Manage 3D Settings
    -> Program Settings
      -> Unity
        -> High-performance NVIDIA processor

This solved the problem for me.

\$\endgroup\$
  • \$\begingroup\$ Thanks! but a dude on unity support helped me, i just switched the render from DX11 to DX9 and everything is cool now, he said it was a known bug, so, yea, thanks anyway =) \$\endgroup\$ – khofez Sep 8 '16 at 20:14
0
\$\begingroup\$

According to this thread, an issue similar to this is known and a fix is in the works.

As a temporary workaround, users report that running Unity with the command line flag:

-force-gfx-direct

will force the editor to run single-threaded and stop the issue from occurring.

You can add this flag to the shortcut you use to run Unity. Let me know if you need instructions how.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.