0
\$\begingroup\$

I'm currently trying to import objects to my game. My problem is that I'm able to load objects from online-sites but it doesn't work for my own objects. It gives me an error:

Debug assertion failes. Expression: vector subscript out of range.

So I watched the value of my vector and realized that the faces are empty. The difference between my obj and these from the internet are that in mine the faces are like:

f 53//51 69//51 54//51

And in the files from online they look like:

f 3551/5154/3181 3666/5155/3182 3543/5151/3178

What do I wrong at exporting my blender-object. I took a screenshot of my settings:

enter image description here

I hope you can help me.

\$\endgroup\$
1
\$\begingroup\$

Sorry for this question. I solved my problem. But I'll leave this post with it's answer here. I forgot to add my uv texture cords correctly. To do this in blender I pressed 'u' and chose "Smart UV Project" in edit-mode. This worked but gave me interesting uv's. To mark your uv's on your own in the edit-mode you can select the vertices you need. Press ctrl + 'e' and select "Mark Seam". Then export your project again and it should work.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.