1
\$\begingroup\$

The entire game takes place in ortho with the exception of the background layer which is drawn on a perspective camera.

Everything seems to be working well except that the background is displaying over the orthographic layer. I've tried fidgeting with the layers, orders and depth of cameras but I'm coming up dry.

Take a look at the pics and you may see what I mean.

Game View Editor View

\$\endgroup\$
1
  • 1
    \$\begingroup\$ Sorry but it's not clear what you're trying to achieve here. What the result should look like? Your structure uses a Sprite Renderer or a mesh renderer? \$\endgroup\$
    – lvictorino
    Apr 3, 2016 at 18:20

1 Answer 1

4
\$\begingroup\$

A higher Depth-setting means that the camera will rendered above cameras with a lower Depth-setting. As you have currently configured your cameras, the orthographic camera is drawn first and the perspective camera above it afterwards. Set the depth of the foreground-camera to a higher value than that of the background camera.

When you do that, you will only see the foreground and the skybox for now. The reason is that the Clear Flags of the foreground-camera is set to "Skybox", so the output of any lower-depth cameras gets replaced with the skybox. Set the clear-flag of the foreground-camera to "Depth Only" and only that of your lowest-depth camera to something else (in this case I would recommend "Solid Color" set to pure black).

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .