1
\$\begingroup\$

I have a model of an SMG with arms exported from Blender and set to generic rig in unity import settings. I was creating an animation for this model in Unity Animation tab, it included changes in position and rotation of the individual parts like magazine and left arm and gun itself. Then when I was satisfied with how the animation worked (I saw it by pressing the play button IN THE ANIMATION TAB). My problem is that when I click play IN THE GAME TAB there is no rotation and some movement, only some parts move (but not rotate). Does anyone know what could be my problem? I am not sure what screenshots to post so tell me what you need to see and I'll add some. Thanks in advance.

\$\endgroup\$
  • \$\begingroup\$ Are all the animation clips based off of one animation controller? \$\endgroup\$ – Justin Markwell Feb 17 '16 at 16:21
  • \$\begingroup\$ There is only one animation so far \$\endgroup\$ – Vadim Tatarnikov Feb 17 '16 at 16:22
  • \$\begingroup\$ And in the game when you are supposed to play the animation does it fire in the animator tab? \$\endgroup\$ – Justin Markwell Feb 17 '16 at 16:23
  • \$\begingroup\$ No it doesn't, the red line just stays at 0:00 \$\endgroup\$ – Vadim Tatarnikov Feb 17 '16 at 16:26
  • \$\begingroup\$ Oh sorry I misread your comment, it does show me in the animator tab that the animation is playing. \$\endgroup\$ – Vadim Tatarnikov Feb 17 '16 at 16:33
2
\$\begingroup\$

I got this to work. The problem was that I enabled "Apply root motion", when I disabled it the animation worked properly.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ Thanks for sharing, saved me some time :) \$\endgroup\$ – Frank Martin May 5 '19 at 10:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.