0
\$\begingroup\$

I'm upgrading my libgdx project to make use of all the new Gradle stuff.

However I changed the package namespace from the default generated by gdx-setup but that hasn't worked: when I debug to my phone Gradle is still trying to launch the default activity using the old namespace, hence it fails. But I can't figure out where Gradle is getting this from - I've searched the entire folder tree for the offending old namespace string and can't find it anywhere.

Details:

So gdx-setup generated the android project with namespace "com.wibble.mygame.android"

To match the namespace of my already-published game, I edited that to "com.wibble.mygame_a". I did this in the Android.manifest and the source code. Also noticed that the android build.gradle file has a line that generates the am start command so corrected that as well.

But when I debug with my connected Android device, it tries to launch the app with a command like:

am start -n "com.wibble.mygame.android/com.wibble.mygame_a.AndroidLauncher" 
   -a android.intent.action.MAIN -c android.intent.category.LAUNCHER

the old namespace is still there but I can't figure out where its getting it from because I can't find any mention of 'mygame.android' anywhere in the whole project tree. Is there some cache of stuff hidden somewhere that I need to delete?

\$\endgroup\$
0
\$\begingroup\$

Clearing out the IntelliJ project and files and re-importing from the gradle.build solved the problem. IntelliJ must have been caching something somewhere.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.