2
\$\begingroup\$

I have an interior scene where I have imported a model for the apartment and many of the interior objects such as lamps, windows, etc. Unfortunately I have a lot of jagged edges on almost all the objects in my scene even on Fantastic Quality settings with Anti Aliasing pushed to its maximum. What else can I do to reduce the jaggies seen here:

enter image description here

Here are my quality settings:

enter image description here

And here are my model import settings:

enter image description here

\$\endgroup\$
  • \$\begingroup\$ Looks like its time to upgrade your game engine ... that one sucks ... don't worry im in the same boat too ... \$\endgroup\$ – War Feb 8 '16 at 22:56
  • 1
    \$\begingroup\$ I don't think @Wardy is correct that it's an engine limitation - antialiasing in Unity is possible. My suspicion is that one of the materials, post-process effects, or camera behaviours in your scene has a side effect that disables or limits anti-aliasing when active, even though it's enabled in the game-wide settings. Can you show us more details of the content of your scenes? Or, try creating a scene with only a default cube in it, verify that anti-aliasing works in this simple case, and then add other scene content one-by-one until you find which piece it is that's disabling AA. \$\endgroup\$ – DMGregory Feb 9 '16 at 2:01
  • \$\begingroup\$ I don't think you have Deferred Rendering on, but if you do, turn it off. On my PC (laptop) 8x AA looks as smooth as ever in the editor. If you're talking about the jagged lines in the reflections, you'll have to increase the resolution of the Reflection Probes. \$\endgroup\$ – EvilTak Feb 9 '16 at 9:04
3
\$\begingroup\$

Hi i had the same problem, but i managed to solve it. The problem was in my GPU Settings. Currently an NVidia card. And in the Antialiasing settings the "Antialiasing - Mode" was set "Override any application setting" and i changed it to "Application-Controlled". In addition i changed the Deferred Rendering On. Afterwards i restarted Unity and the problem was gone.

\$\endgroup\$
0
\$\begingroup\$

Are you sure you are not using deferred rendering? MSAA is not available with it.

\$\endgroup\$
-4
\$\begingroup\$

Use SMAA injector and downsample. Far superior. Multisampling is ancient garbage.

\$\endgroup\$
  • 3
    \$\begingroup\$ please explain more or add this answer as comment \$\endgroup\$ – Seyed Morteza Kamali Aug 26 '16 at 7:42
  • \$\begingroup\$ Sources and citations? \$\endgroup\$ – Krythic Oct 21 '16 at 13:21

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.