1
\$\begingroup\$

I'm following Ben Tristem's latest course on using Unreal Engine and coding in C++. I have issues getting into Unreal however: when I create a project, it does its stuff, i.e. generates code, compiles it etc. but then I get this message:

screenshot of a terminal

I tried to open it with Xcode but I don't know what to do next… could someone help me out?

\$\endgroup\$
  • \$\begingroup\$ Which branch did you pull the source from? \$\endgroup\$ – Syntac_ Feb 3 '16 at 10:04
  • \$\begingroup\$ I don't understand...all I did was start a new c++ project and opened it, then this happened... \$\endgroup\$ – mr-matt Feb 3 '16 at 18:23
  • \$\begingroup\$ Have you tried a different version of the engine, it looks like it's just missing the override keyword which that compiler requires but MSVC doesn't, so they often get fixed up later. \$\endgroup\$ – Syntac_ Feb 5 '16 at 10:06
2
+50
\$\begingroup\$

The answer at https://answers.unrealengine.com/questions/274013/fresh-install-new-c-third-person-project-doesnt-co.html suggests that you are using a version of OSX or XCode that is not currently supported by Unreal Engine. I don't know the version you are using, but you should check the UE documentation and make sure you have the correct versions.

Otherwise you could just try to edit the method declaration in the error to override. See http://en.cppreference.com/w/cpp/language/override for reference.

| improve this answer | |
\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.