0
\$\begingroup\$

I have created a die in blender, that uses two materials. One material is transparent and the second is opaque.

When I look throught the die, I expect to see the opaque parts blocking the view, but I do not see them at all.

enter image description here

As you can see in the image above, the 6 dots on the back of the die are not shown, it just looks like it is empty.

What can I do to fix this?

\$\endgroup\$
2
\$\begingroup\$

You don't see the back faces of a model because the model's faces are one sided. By default, for most applications, faces are one sided. Some programs (such as Sketchup) render faces double-sided by default (I use Sketchup frequently, and also have to regularly flip the surface normals before importing into Unity). I do not know about Blender, but I suspect it double-side-renders by default as well.

I am not sure how to go about making the faces dual-sided (I am not a Blender expert) but an alternative solution would be to duplicate the model file, flip that model's normals, and use both the right-side-out version and inside-out version as one prefab.

\$\endgroup\$
  • 1
    \$\begingroup\$ Adding to that: Not sure about blender/unity, but you may get weird visual behaviours because of the render order of the objects with the depth sorting. Worst case scenario, you'll have to draw each face independently instead of as a group. \$\endgroup\$ – Alexandre Vaillancourt Jan 15 '16 at 20:00
  • \$\begingroup\$ ah, this is very interesting. I made the model in blender, let me try making the material transparent in belnder, and see how it renders it. Thanks for the tip. \$\endgroup\$ – nycynik Jan 15 '16 at 20:06
  • \$\begingroup\$ @nycynik The automatic "culling" of one-sided polygons happens because it is super cheap (comparison of the normal direction and the camera facing direction) and for non-transparent objects you would never know it happened. You can see the effect any time you can get a camera to clip through objects in...pretty much any game ever. There are a few exceptions (Steve's head in Minecraft, for example). \$\endgroup\$ – Draco18s Jan 15 '16 at 20:12
  • \$\begingroup\$ Okay, I was not sure if there was a simple fix, like something in the drop down for the normals in blender. \$\endgroup\$ – nycynik Jan 15 '16 at 20:22
  • \$\begingroup\$ @nycynik Yeah, it depends on the program. I believe Maya and 3D Studio have options for it. I know Sketchup does not and I'd have to check my UV editor, LithUnwrap (it has an option for flipping the normals, but I don't think it can make them double-sided). \$\endgroup\$ – Draco18s Jan 15 '16 at 20:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.