3
\$\begingroup\$

I've been working on a monogame project for a little over a week and had no problems. Today I went to test out the project outside of Visual Studio, by running directly from the .exe in the release folder. When I click on the .exe I get the cursor icon indicating something is loading, but nothing ever does. No window shows up, even though I see processes related to my game in the task manager. Also when I try to end mygame.exe in the taskmanager it doesn't work and the process still sits there.

I've tried both a Windows and Windows OpenGL monogame project and both hang once I click the exe. Does anyone have any idea why this may be or any steps I might take to track down the issue?

I'm using Windows 7, Visual Studio Community 2015 and the latest Monogame Build. My project references Farseer Physics, Lidgren, Json .Net, and my own Utility class library.

Edit: I tried creating a brand new Monogame project and run it without debugging in VS and it hangs the same way running from the .exe does. Also the project runs when placed on my laptop which also has monogame installed so it's nothing wrong with the project.

\$\endgroup\$
  • \$\begingroup\$ You can start it that way and then attach the debugger to an already running process (Debug->Attach to process), that might give you some more information. Though what I guess is happening is that visual studio starts it from a different running directory and it's trying to load some files that don't exist. \$\endgroup\$ – Elva Dec 16 '15 at 21:51
  • \$\begingroup\$ Perhaps add some logging to your project? \$\endgroup\$ – craftworkgames Dec 17 '15 at 2:10
  • \$\begingroup\$ @craftworkgames How would I go about this, and what would I be looking for? \$\endgroup\$ – Saliken Dec 17 '15 at 16:09
  • \$\begingroup\$ @KevinvanderVelden I've tried attaching the debugger but it breaks right away and I haven't been able to get any extra info. I agree that it's probably missing some file. \$\endgroup\$ – Saliken Dec 17 '15 at 16:10
1
\$\begingroup\$

So I was sitting here staring at my computer wondering why it absolutely refused to run my program, and then it hit me. I wen to my anti-virus, turned it off, and voila, it works. I don't know why Avast didn't come up with some sort of message about the program being unsafe or anything, but at least now I know what the problem was. I'm a little worried about what these means for anyone else running the same AV but at least I can start developing again.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.