7
\$\begingroup\$

I cannot make assimp object loader work with universal app, and I got the same problem as this one: Assimp and directX12 universal apps

I tried the static library approach mentioned in the answer of that question. In the Properties->Linker->Link Library Dependencies, 'Yes' was selected by default. I also added the path of assimp.dll to Linker->General->Additional library directory, and added assimp.dll to Linker->Input->Additional Dependency. Yet no help. I'm not sure if I did correctly to link it statically or it's just because it didn't work.

Or is there any other api can be used just like assimp?

\$\endgroup\$
2
  • \$\begingroup\$ That library can actually be linked statically to an executable (no DLL), I have done that myself a couple times on Mac and Linux, though have never tried on Windows. It takes a bit of work, but should be doable. Another option might also be just embedding the whole source tree into your own project and building everything together, shouldn't be too hard either... \$\endgroup\$
    – glampert
    Dec 16, 2015 at 19:04
  • \$\begingroup\$ I think I had to rebuild the dll and lib using cmake. I put the lib in the immediate directory and the dll next to the dll in .../Debug/AppName/AppX/ so that it was next to the exe. I just opened the project and it works. I didn't have to do anything that guy answered in that question. Also don't forget your includes in Vc++ Directories and to add the lib name in Linker>Input->Additional Dependencies \$\endgroup\$ Dec 21, 2016 at 21:49

0

You must log in to answer this question.

Browse other questions tagged .