1
\$\begingroup\$

EDIT: I've discovered the cause of the problem and it might make more sense if I continue in another question.

To start with unity has decided that lighting inside reflection probe bounding boxes is different : Different lighting in reflection probes

This is fixed by disabling the probe but this isn't an acceptable solution. I have no idea how to fix this.

Secondly: Unity has decided to make my shadows flicker on and off (btw: kinda in sync to me pressing my mouse buttons) Disabling the probes once again helped but this time did not solve the problem completely as the shadows would still flicker between resolutions. No shadows???

Oh and I've been getting these bugs and no shadows at all sometimes:

rc.right == m_GfxWindow->GetWidth() && rc.bottom == m_GfxWindow->GetHeight()
GUI Window tries to begin rendering while something else has not finished rendering! Either you have a recursive OnGUI rendering, or previous OnGUI did not clean up properly.

Please could someone help because I really don't understand why this is happening. Thanks...

Edit: I was told that it would be necessary to detail what I've already done and some more information on the scene.

What I've tried:
Updating to the latest release of Unity (5.2.3f1)
Adjusting the near and far clipping planes
Turning things on off (GameObjects)
Changing the shadow settings (Shadow cascades, shadow distance)
Changing between Realtime and Baked Lighting and GI
Clearing the GI cache
Switching between deferred and forward rendering

If there's anything else anyone needs to know I will more than happily add it here because as I say I have no idea what you need to know to solve this.

\$\endgroup\$
  • 1
    \$\begingroup\$ There's not enough information here for us to help. It's not really clear what you're asking (something about probing and shadows being broken). It's also not clear if it's a unity bug vs. a big in your code (which we don't have much of). Maybe you can start by asking on the Unity Q&A site if these are known bugs, or by trying to reproduce in an older version of Unity to see if it is indeed version 5 that's broken. \$\endgroup\$ – ashes999 Dec 2 '15 at 17:26
  • \$\begingroup\$ @ashes999 The problem is that I really don't know what information you need to solve. But I'll see if I can edit the original post and mention what I have tried already. \$\endgroup\$ – Thomas Mathieson Dec 3 '15 at 5:14

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.