3
\$\begingroup\$

So my problem is that other than for static objects which have baked shadows from building lighting, there are no shadows for movable objects, like those cubes. Neither from the Light source actor, which is stationary, nor from Point lights that are either static or moveable. enter image description here

I may be wrong but I think it used to have dynamic shadows (or I didn't notice the lack of them until recently). So any ideas how to get dynamic shadows? Thank you

\$\endgroup\$
1
\$\begingroup\$

You will need to configure your lighting for your project as well as for your objects when you want dynamic shadows. I suggest taking a look at this lighting section for UE4: Lighting and Shadows Reference

Also, check your In-Editor Graphics quality as well as the buffer you are rendering in the Editor.

\$\endgroup\$
0
\$\begingroup\$

I changed my Directional Light from Stationary to Moveable and this fixed my issue, which was similar to yours.

Select your Directional Light and under the Details Tab you'll see the Transform drop down. Under the coordinates, there are 3 options, Moveable being one. Select that and, fingers crossed, it'll be the fix.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .