1
\$\begingroup\$

I've been having some problems with the pipeline in MonoGame. I'm using Visual Studio Community Edition 2015 with MonoGame 3.4. I used the installer rather than NuGet if that helps with the problem. Originally the templates went into another users folder and I had to copy them out. I have all of the templates installed in the correct area but when I double click the Content.mgcb icon on the right side of the screen it opens up this file:

#----------------------------- Global Properties ----------------------------#

/outputDir:bin/Windows
/intermediateDir:obj/Windows
/platform:Windows
/config:
/profile:Reach
/compress:False

#-------------------------------- References --------------------------------#


#---------------------------------- Content ---------------------------------#

Thanks!

\$\endgroup\$
  • 1
    \$\begingroup\$ Right click the .mgcb file and choose "Open WIth". What options do you have available? The correct program should be called "Monogame Pipeline" \$\endgroup\$ – tandersen Nov 22 '15 at 21:39
4
\$\begingroup\$

What it looks like you're seeing is the file opening as a plain text in Visual Studio. I often open the file this way because I find it handy to be able to edit stuff outside the GUI.

As mentioned by @tandersen, if you right click the Content.mgcb file in Solution Explorer you can choose "Open With..." to get the following dialog.

MonoGame Content Pipeline Open With Visual Studio

If you can't see the MonoGame Pipeline Tool in the list you'll need to "Add..." it manually. This can be a little tricky because it installs into an odd folder by default.

On my machine the Pipeline.exe is located here:

C:\Program Files (x86)\MSBuild\MonoGame\v3.0\Tools

Once you've added it and "Set as Default" it should open by double clicking the Content.mgcb file.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.