I'll be honest, I'm stumped, I've been trying all night, googling away, made multiple attempts and failed every time. The library in question that I'm trying to add to my project is:


The instructions say:


1. Install the project into your Maven repository (since it is not available in the Central Maven repository).

2. Include the Maven dependency into your project:


3. There is no need to extract or copy the native libraries from the VS project. The natives are included in the jar file and are extracted and loaded at runtime automatically under the lib folder of the working directory.

4. In your Java code, import the com.ivan.xinput.XInputDevice class for XInput 1.3 functionality or com.ivan.xinput.XInputDevice14 for XInput 1.4. The latter class extends the former so you can use 1.3 methods with the 1.4 class.

5. To check if the desired version is available:

// check if XInput 1.3 is available
if (XInputDevice.isAvailable()) {
    System.out.println("XInput 1.3 is available on this platform.");

// check if XInput 1.4 is available
if (XInputDevice14.isAvailable()) {
    System.out.println("XInput 1.4 is available on this platform.");

I'm using the current latest version of Eclipse and have the latest version of Java installed. I have a simple project I'm working on, just a JOGL based 3D application.

The first step says, "1. Install the project into your Maven repository". This is where I'm most confused.. I've never used Maven before, I don't know how to use it. After some googling, I unzipped the project into my Eclipse workspace and tried going to File > Import > Maven > Existing Maven Projects and imported the project.

Next the instructions refer to Maven dependency. I tried setting the dependency on the maven project, but I'm not sure if I was even in the right place for that.

The 3rd instruction refers to natives included in a Jar file, but after much searching I can't find a Jar file inside of any of the files provided by the library.

After that I tried to follow the rest of the instructions but obviously nothing has worked. I've fiddled with many settings and tried what I can all night to make this work but I can't see what it is I'm meant to do.

Can anyone give me any hints? Has anyone done this before who can give me a quick howto on this? I just don't know what I'm meant to do, any help would be greatly appreciated.


1 Answer 1


Ultimately my problem turned out be just a silly issue of needing to reinstall the JDK! After doing that, everything was working again.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .