1
\$\begingroup\$

Mixamo (now Adobe Mixamo) allows us to choose character and then animations from its website from free samples. I have done one simple animation and added the model to Unity. The animation works fine but the model is very changed once being imported, have a look here.

enter image description here

I am using following import settings,

Format: Fbx for Unity

Skin: With Skin

FPS: 30

Keyframe Reduction: Uniform

I tried "Fbx" format only too, but no luck.I also applied "humanoid" in rigging, but I think it is not relevant here. Since I am not good with modeling that is why I am using this service, and I have no idea how to tackle this. Once it did worked well, but unfortunately I could not remember how, so I am stuck again.

\$\endgroup\$
  • 1
    \$\begingroup\$ This looks like inverted normals. Is there an option for that somewhere? (In Mixamo as well as Unity). Also, check the material in Unity. It might be set to Transparent/Bumped Diffuse. Switch that to a non-transparent one \$\endgroup\$ – Dries Oct 24 '15 at 21:59
  • 1
    \$\begingroup\$ You may want to add this as answer since it solved the problem :) \$\endgroup\$ – Talha Oct 25 '15 at 16:56
2
\$\begingroup\$

This looks like inverted normals. Is there an option for that somewhere? (In Mixamo as well as Unity). Also, check the material in Unity. It might be set to Transparent/Bumped Diffuse. Switch that to a non-transparent one

\$\endgroup\$
  • \$\begingroup\$ Right, set Material type to Legacy/Diffuse or Mobile/Diffuse and now works perfect. Thanks. \$\endgroup\$ – Talha Aug 10 '17 at 4:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.