1
\$\begingroup\$

Android

In the Unity editor, the lowest available Android version for debugging is Android 2.3.1 In my case, I have a phone running an older version of Android and I intend to publish my game to a wide audience. With the lowest version being 2.3.1, I see a problem publishing my games to older smartphones which still occupy a considerable size of the market share. My question is: Is there a way to publish my game to older versions of Android? Or is it impossible?

\$\endgroup\$
5
  • 3
    \$\begingroup\$ geez 2.3.1 came out in 2010 and that's not old enough? damn yo; I'm not sure Unity even built to Android before then. \$\endgroup\$ – jhocking Oct 21 '15 at 17:25
  • \$\begingroup\$ Aight. I did not formulate my question very well. What I meant is that devices with Android 2.3.1 or less still represents a relatively large number of smartphones, especially in developing countries. \$\endgroup\$ – That's me. Oct 21 '15 at 17:29
  • 1
    \$\begingroup\$ There's a reason I wrote a comment and not an answer. I understood your question perfectly well. \$\endgroup\$ – jhocking Oct 21 '15 at 17:51
  • 2
    \$\begingroup\$ Pre gingerbread occupies 0.2% of the market according to Google; developer.android.com/about/dashboards/index.html#Platform and it was quite a big change between froyo and gingerbread so it's painful to go pre gingerbread. Personally even supporting gingerbread (3.8%) is only worth it if it doesn't compromise your design \$\endgroup\$ – Richard Tingle Oct 21 '15 at 20:04
  • \$\begingroup\$ I'm voting to close this question as off-topic because it is a duplicate of: stackoverflow.com/questions/33264936/… \$\endgroup\$ – MichaelHouse Nov 11 '15 at 17:59
2
\$\begingroup\$

Quoting Bart from the same question on Stack Overflow:

Versions later than Unity 4.2.x don't support Android versions earlier than 2.3.x. So if your project relies on functionality only present in 4.3.x and higher, you're out of luck.

Otherwise you can still download a 4.2.x or earlier version of Unity and create your builds with that.

\$\endgroup\$

Not the answer you're looking for? Browse other questions tagged or ask your own question.