1
\$\begingroup\$

When I try to execute a game code fully functional on Visual Studio 2013, using Cocos-2D (3.8.1) library this error jumps on screen. (I'm working on a laptop)

Error Window 1

OpenGL 1.5 or higher is required (your version is (null)). Please upgrade the driver of your video card.

And then this one:

Error Window 2

My Graphic card is an AMD Radeon HD 7600M (OpenGL version 4.x), with de drivers fully updated.

Neither my college teacher nor me know how to fix it.

What can I do to fix it?

\$\endgroup\$
5
  • \$\begingroup\$ What cpu does your laptop have? Does it have onboard graphics? This happend to me where any apps I opened used the onboard graphics (Intel HD 3000). Through some intel control panel I was able to tell it to use the geForce graphics card by default instead of the HD 3000. \$\endgroup\$ – Soapy Oct 21 '15 at 14:06
  • \$\begingroup\$ I thought that too, but my laptop uses by default the AMD graphic card (I don't know if Visual Studio doses). The CPU is an Intel i7-3630 with 2.4GhHz. \$\endgroup\$ – Zoroastiran Oct 21 '15 at 14:09
  • \$\begingroup\$ What model is your laptop? And what model CPU does it have? \$\endgroup\$ – Soapy Oct 21 '15 at 14:11
  • \$\begingroup\$ A Toshiba Satellite L850 The CPU is an Intel i7-3630 with 2.4GhHz. \$\endgroup\$ – Zoroastiran Oct 21 '15 at 14:15
  • 1
    \$\begingroup\$ Have you tried setting the app you compile to high performance in the catalyst control centre? Check this site out. \$\endgroup\$ – Soapy Oct 21 '15 at 14:24