2
\$\begingroup\$

I added particle system package from assets, selected hose particle system and put it in the scene. When I select 'Water Shower', it works in the scene preview, but on play, it just appears and vanishes in a fraction of a second. I set Looping, Play on awake enabled already, no result.

I also get the same result in a separate otherwise empty project.

enter image description here

Is this the problem with the prefab or there is something else I need to set to make it work properly?

I am trying to use hose particle system to create fountain like effect. I have used Steam particle system from same package, and it renders in play mode fine.

I know this is similar to this StackOverflow question. I have already tried the solutions provided there, and the asker also has not yet marked answer as a solution.

I've also made a video of what is happening.

\$\endgroup\$
1
\$\begingroup\$

You can fix that issue by disabling the scripts on the parent object of hose, Happy Game Development.

As directed below in picture, disable both red circled scripts.

enter image description here

If still problem persist you can ask in detail.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.