1
\$\begingroup\$

I'm making a game in Unity, and i want to know if I generate the apk in version 4.1 Jelly Bean he will run in newest versions of android? Can anyone explain me better how the version works?

\$\endgroup\$
  • \$\begingroup\$ fyi I changed the title to better reflect your actual question (the bit about Unity really has nothing to do with it). \$\endgroup\$ – jhocking Oct 13 '15 at 19:25
  • \$\begingroup\$ Android applications have a minSdkVersion and a targetSdkVersion. The targetSdkVersion should be the highest available (it is 22 in a random non-unity project I am working on, just to give you an idea) and the minSdkVersion is usually 8 or 10 which is usually the lowest android version that someone will have on super old android phones. \$\endgroup\$ – dimitris93 Oct 13 '15 at 20:02
  • \$\begingroup\$ Ok, but in Unity i can only select one version, I want to know if I select this version my game will only work in the selected version? Or have some way to configure in Unity the minSdkVersion and the targetSdkVersion? \$\endgroup\$ – Esmigol Oct 13 '15 at 20:14
  • 1
    \$\begingroup\$ I'm not sure how to set those within Unity, but you can set those in the manifest file with a line like <uses-sdk android:minSdkVersion="9" android:targetSdkVersion="19" /> \$\endgroup\$ – jhocking Oct 13 '15 at 20:33
  • 1
    \$\begingroup\$ Lookup "unity android manifest" for information about working with that; I think this will get you started stackoverflow.com/questions/17241364/… \$\endgroup\$ – jhocking Oct 13 '15 at 20:34
1
\$\begingroup\$

Yes it will work.
if you set the game to 4.1 Jelly Bean it will work for the 4.1 and all the higher versions of android, here is a link for better explanation: https://www.udacity.com/course/viewer#!/c-ud853/l-1395568821/m-1643858570

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.