1
\$\begingroup\$

I'm familiar with Unity and programming but I'm new to this site.

So I have an issue with clients on Unity. I start servers with no errors, flawless. But when I join a server as a client I get a bunch of the error mentioned in the title. What causes this issue? I am using the UNET networking components.

I think it's lines like these, when executed by a client:

    NetworkServer.Spawn (objectNameHere);

How can I fix it if that's the case?

Edit

After hours of having this issue I have become so frustrated that I think it's best I take a break. I'll check back on this site from time to time.

\$\endgroup\$
5
  • \$\begingroup\$ Just doesn't make sense. I wanted to play my game with my brother soon. It would be really nice if someone managed to see this before then. \$\endgroup\$ Oct 10, 2015 at 23:58
  • 1
    \$\begingroup\$ I think it would be more helpful if you provide more details such as your code \$\endgroup\$
    – Xeon
    Oct 12, 2015 at 6:09
  • \$\begingroup\$ An example of the errors wouldn't so amiss either. We need more details if we're going to help you out. \$\endgroup\$ Oct 13, 2015 at 11:18
  • \$\begingroup\$ I found out it wasnt my code, but I didn't assign something in the editor :) \$\endgroup\$ Oct 13, 2015 at 11:23
  • \$\begingroup\$ You should post back an answer so that when someone else is stuck you're helping them in the same way these people tried to help you. \$\endgroup\$
    – Mrk Fldig
    Oct 17, 2015 at 19:02

1 Answer 1

0
\$\begingroup\$

I was having the same trouble, and figured it out. In my Player prefab, under the Network Identity component I had not checked "Local Player Authority". Once I checked this all subsequently behaved as expected.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .