0
\$\begingroup\$

I have a FP Character and well, it can't look vertically. Its happened about 3 times now, each time I just replaced it with the standard assets prefab, first few times it worked fine, but then after a little while, I suddenly couldn't look vertically. I have checked and double check the vertical clamping on the prefab and they haven't been touched. I really need my player to be able to look vertically as soon as possible, could someone show me how to fix this?

Thanks in advance!

\$\endgroup\$

4 Answers 4

0
\$\begingroup\$

The Fix:

With Unity 5, they change the setup of FPController Scripts so theres no more MouseLook script. The old MouseLook Script is called SimpleMouseRotator. With Referencing the SimpleMouseRotator, it got the vertical axis back for him and disabling the camera from the First Person Character.

Do you have any error or warning on console like audio listeners that needs to be deactivated?

Also try placing 2 mouselook script but deactivate one of them. Then when you lose vertical look, deactivate the current and enable the second one. See if that worked in getting vertical look back?

Are you changing anything from the FP prefab by any chance like height or width of character?

\$\endgroup\$
9
  • \$\begingroup\$ No I don't have any errors in the console. I haven't directly changed the height or width of the character, but I do have it parented to an empty for other reasons and that empty is scaled at 0.4, 0.4, 0.4. As for the mouse look script there isn't actually one on there, but it is referenced in the First Person Controller script and referenced in the inspector of the FPSController object. \$\endgroup\$
    – mr-matt
    Oct 12, 2015 at 4:06
  • \$\begingroup\$ I would suggest you have that script attached to the gameobject/FPS object. I tried the basic FPS controller in standard asset and unchecked the mouse look script and then I lose my horizontal movement but have vertical mouse movement. \$\endgroup\$ Oct 12, 2015 at 4:52
  • \$\begingroup\$ Just tried to, says "Can't add script behavior MouseLook. The script needs to derive from MonoBehavior." \$\endgroup\$
    – mr-matt
    Oct 12, 2015 at 5:21
  • \$\begingroup\$ Thats weird, is the MouseLook script C#? If yes, just modify the line inside the script, public class MouseLook -> public class MouseLook:MonoBehaviour. If not, try the standard mouselook script comes package with Unity. \$\endgroup\$ Oct 12, 2015 at 5:26
  • \$\begingroup\$ Ok, well now the script is on the object, however I can't enable/disable it, the checkbox is missing for it, and I can't move the player at all... \$\endgroup\$
    – mr-matt
    Oct 12, 2015 at 5:38
1
\$\begingroup\$

I just found exact problem as you did, so what you need to look for are some extra cameras that you don't remember putting in your game, when you found the camera that somehow added itself in, delete it. If that didn't work press Ctrl+Z to reverse the action you have just done and find a different camera to remove.

Hopefully I solved the problem but your post was made 4 months ago, so I think you already have made new game/scene.

\$\endgroup\$
0
\$\begingroup\$

This is the easy solution, if your FPS Controller stops looking up and down, after you import a new big asset package, like the Post Processing Stack:

1. Go to Assets > Reimport All

2. Select your default "Main Camera", in the Inspector change it's Tag to "Untagged".

That's it. The Main Camera thing, it's because the FPS Controller child, FirstPersonCharacter, has it's own Camera component tagged "Main Camera". And there can be only one.

\$\endgroup\$
-1
\$\begingroup\$

I just duplicate fsp and delete old one usually works but i think it is a bug. Delete all the main cameras that's what its. So much time duplicating and attracting stuff. DELETE MAIN CAMERAS.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .