2
\$\begingroup\$

I believe MonoDevelop (bundled with Unity3D) has changed its ctrl-tab and ctrl-shift-tab behavior and I would like to get back to the old behavior, as the new way frustrates my workflow.

Ctrl-tab (and ctrl-shift-tab) previously (and ought to) go to the "last viewed tab", in a similar way to how alt-tab works on Windows. Unfortunately there seems to have been a change and now it goes to the "tab on the left of the current one".

An example of why this is frustrating: quickly looking at a class definition, you hit F12 to load the definition (perhaps in a new tab), and then you want to go back to the code you were working on. Previously you could hit ctrl-tab and you'd be back there. Now you can't do that and you have to actually remember what you were doing, which isn't good for my workflow (read: ailing memory).

I'm not sure when the change happened, or if it's a setting somewhere (I can't find it). I'm running Unity 5.1.2p2 and its bundled MonoDev 4.0.1. Noticed it after a clean install of Windows 10.

How can I fix this to revert to the old behaviour, or is there some other method to jump back to the last viewed tab?

It seems pedantic but it has a major impact on my productivity.

\$\endgroup\$
2
  • \$\begingroup\$ I'm voting to close this question as off-topic because it is about how to use or configure MonoDevelop. \$\endgroup\$ – user1430 Aug 21 '15 at 3:50
  • 1
    \$\begingroup\$ It's about MonoDevelop as configured, bundled and installed by Unity3D. There are many Unity questions in this forum, but you can move it to another stack exchange site if you want. It's already answered anyway. \$\endgroup\$ – Qubei Aug 21 '15 at 4:06
1
\$\begingroup\$

http://answers.unity3d.com/questions/613355/document-switcher-is-gone-monodevelop.html

Edit C:\Users\ USERNAME \AppData\Roaming\MonoDevelop-Unity-4.0\Config\MonoDevelopProperties.xml

Set the MonoDevelop.Core.Gui.EnableDocumentSwitchDialog property to True

\$\endgroup\$
1
  • \$\begingroup\$ Thank you! That edit to %APPDATA%\MonoDevelop-Unity-4.0\Config\MonoDevelopProperties.xml did the trick. \$\endgroup\$ – Qubei Aug 21 '15 at 3:43

Not the answer you're looking for? Browse other questions tagged or ask your own question.