2
\$\begingroup\$

As of unity 4.5.3, Screen.SetResolution and the Unity Resolution Display Dialog, by default, no longer change the monitor/desktop resolution. Instead, it only changes the render target resolution for the game. This means that if you run a 1024x768 resolution on a widescreen monitor, your cursor can travel into the letterboxed area, outside of the window bounds, even when running in full screen mode. This is not the desired behaviour for our game.

This was described in the Unity 4.5.3 release notes:

"Windows Player: The default full-screen mode no longer changes the desktop resolution, so things like IME text input work."

I would like to actually change the desktop resolution. The change log suggests there is some non-default full-screen mode that will actually change the desktop resolution... How do I do this?

\$\endgroup\$
1
\$\begingroup\$

It's under

PlayerSettings> Settings for Pc, Mac and Linux standalone> StandAlone Player Options> D3D9 Fullscreenmode and D3D11 Fullscreenmode

But I find it kinda buggy;

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.