-1
\$\begingroup\$

I have made a small game for testing purposes and a packaged the game, and ran my game but when I run it, it runs with the UTdeathmatch type game. and I made my DefaultGame to DefaultGame=UDKBase.SimpleGame but still I have a gun in my hand doesn't work How do i fix that?

\$\endgroup\$
  • \$\begingroup\$ Was my answer helpful? \$\endgroup\$ – Phillip Aug 3 '15 at 13:56
0
\$\begingroup\$

Which map are you running? The map can also specify which game type to use on it. Look at View->WorldProperties->Default Game Type. I think there's also a game type for Play In Editor mode.

The game type can also be overridden via command-line ("?game=").

Finally, after the engine determines which GameInfo to load, it calls SetGameType() on that GameInfo. This gives you the option of overriding your own game type based on map name, command-line options, etc. (see UTGame::SetGameType()) The default functionality is for the GameInfo to just return its own class, so this feature is entirely optional.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.