I want to build for Android and today one error popped up after building.

Your Android setup is not correct. See Settings in Facebook menu. UnityEditor.HostView:OnGUI()

Important things about this problem:

  • The only error in the inspector I can see is

    OpenSSL not found. Make sure that OpenSSL is installed and that it is in your path.

Even tho I have installed it and added it to my path

  • When I open the inspector in Facebook> Edit Settings, unity becomes very unresponsive

  • This error has not popped up before today

  • I still get a APK even if I get errors
  • \$\begingroup\$ Did you setup anything for android later on ? Keep the backup and try regenerating manifest and build SDK package. \$\endgroup\$ Commented Jul 22, 2015 at 14:22
  • \$\begingroup\$ Does the android manifest not regenerate on every build? \$\endgroup\$ Commented Jul 22, 2015 at 19:57
  • \$\begingroup\$ That is another story, i am saying that i just saw two buttons in inspector which says regenerate manifest and build SDK. I tried with latest facebook unity plugin beta. Do you have that button or which plugin/version are you using ? \$\endgroup\$ Commented Jul 22, 2015 at 21:15

2 Answers 2


There is actually a major bug with the latest version of Facebook SDK and the OpenSSL. Every time you click on Facebook/Settings Unity hang and becomes unresponsive.

I had to download openssl-0.9.8k_X64.zip found here and the problem was solved.

The proper solution was provided on SO.


This question has been answered multiple time at least here.

Here are steps.

  1. Download the OpenSSL installer

  2. Download the lastest x64 JavaSDK here. I have installed the latest Java 8 SDK.

  3. Make sure to use the latest Facebook SDK. Take a look here.

  4. Now you have all the needed files.

  5. So start installing OpenSSL on "C:/OpenSSL" and go to "Control Panel > System > Advanced system settings > Environment Variables" and select the Variable "Path" in the "System variables" window and click Edit. And finally, add the path to your OpenSSL bin folder to the end of the "Variable value" after a ";". For example, using "C:/OpenSSL" install folder, you'll type ;C:\OpenSSL\bin.

  6. You'll have to do the same for JavaSDK. Install it and then add the environment variable. Using Java8, I have putted ;C:\Program Files\Java\jdk1.8.0\bin just after openssl one.

  7. Adding these variables make prompt commands working (like "keytool" or "openssl") but to make it work in Unity, I have had to restart Windows. The problem was here. When I was testing some solutions without restarting, they didn't work. But if you install these packages and configure environment variables like I did and after that, restart windows, when you'll create a new Unity project using the last Facebook SDK, you'll probably not get the warning message telling you "keytool" or maybe "openssl" is not founded.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .