4
\$\begingroup\$

I'm trying to debug some textures and FBO's with Nvidia Nsight 4.6 VS Edition. But when I select either "Start CUDA debugging" or "Start graphics debugging" I get an error.

"The program can't start because glew32.dll is missing for your computer. Try reinstalling theprogram to fix this problem"

The application runs just fine when I'm not using Nsight. What might be my problem?

My system; Windows 7 x64 bit. Nsight 4.6 x64 bit. GTX 580 with lastest drivers. OpenGL version 3.3. Building a Win32 application. (Tried to change the build target to x64 but that just resulted in a bunch of linking errors for glfw and glew)

\$\endgroup\$
  • \$\begingroup\$ Sounds a bit like there's a version conflict (either tool/plugin loading trying to load a different version of glew32?). \$\endgroup\$ – Mario Jun 30 '15 at 12:32
  • \$\begingroup\$ How do I check if there are different versions of the glew32 file? \$\endgroup\$ – Edvin Jun 30 '15 at 13:17
1
\$\begingroup\$

Okey I found the problem. I had placed my glew32.dll file in a separate folder and set the environmental path to that location. e.g: Properties > Configuration Properties > Debugging > Environment = PATH=$(ProjectDir)..\dependencies\bin;%PATH%

Apparently Nsight didn't realize this and thus couldn't find the dll.

\$\endgroup\$
  • \$\begingroup\$ How did you fix the issue? I have the same problem. \$\endgroup\$ – Florian Castellane Jan 17 '17 at 9:50
  • \$\begingroup\$ This was some time ago, so hopefully my memory doesn't fail me here... But you have to place the gew32.dll in the same folder as your binaries. Please reply to this comment if this fixes your issue. \$\endgroup\$ – Edvin Jan 18 '17 at 11:49
  • 1
    \$\begingroup\$ In the end, because I didn't want to move libs (they are a separate project) and since it doesn't look like there is a way to do it in Visual Studio or Nsight, I made a .bat file to set the PATH to my DLLs and then start the program (checked that "application is a launcher" box in Nsight options). \$\endgroup\$ – Florian Castellane Jan 18 '17 at 12:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.